CST DESIGN STUDIO™

WORKFLOW
BLOCK TYPES
SIMULATION TASKS

CST STUDIO SUITE™ 2008
## Contents

### CHAPTER 1 — INTRODUCTION

- Welcome ........................................................................................................................................ 3
- How to Get Started Quickly ........................................................................................................ 3
- What is CST DESIGN STUDIO™? ................................................................................................ 4
- Main applications for CST DESIGN STUDIO™ ........................................................................... 4
- CST DESIGN STUDIO™ Key Features ......................................................................................... 5
  - User Interface .......................................................................................................................... 5
  - Components ........................................................................................................................... 5
  - Analysis ..................................................................................................................................... 5
  - Result Management .................................................................................................................. 6
  - Visualization ............................................................................................................................ 6
  - Documentation ......................................................................................................................... 6
  - Automation .............................................................................................................................. 6
- About This Manual ......................................................................................................................... 7
  - Document Conventions ............................................................................................................ 7
  - Your Feedback ......................................................................................................................... 7

### CHAPTER 2 — QUICK TOUR

- Overview of the User Interface’s Structure ................................................................................... 8
- Creating a System .......................................................................................................................... 10
  - Adding and Connecting Components ...................................................................................... 11
  - Changing Properties of a Block .............................................................................................. 16
  - Changing Properties of an External Port .............................................................................. 17
- Performing a Simulation ................................................................................................................. 19
  - Unit Settings ........................................................................................................................... 19
  - Defining Simulation Tasks ....................................................................................................... 20
  - Starting a Simulation .............................................................................................................. 24
- Visualization of the Results ........................................................................................................... 24
  - Standard Result Views ........................................................................................................... 24
  - Customizing Result View Properties ...................................................................................... 28
  - User-Defined Result Views ..................................................................................................... 30
- Parameterization and Optimization ............................................................................................. 31
  - Using Parameters .................................................................................................................... 32
  - Performing a Parameter Sweep ............................................................................................. 36
  - Performing an Optimization .................................................................................................... 41

### CHAPTER 3 — INTEGRATION WITH CST MICROWAVE STUDIO®

- Integration from the CST MICROWAVE STUDIO®’s User’s Point of View ................................ 51
- Integration from the CST DESIGN STUDIO™’s User’s Point of View ........................................ 57
- Example Introduction .................................................................................................................. 57
- CST MICROWAVE STUDIO® Models ...................................................................................... 58
- CST DESIGN STUDIO™ Modeling .......................................................................................... 61
- CST DESIGN STUDIO™ Simulation ......................................................................................... 64
- Optimization ............................................................................................................................... 69
- Antenna Calculation .................................................................................................................... 73
Chapter 1 — Introduction

Welcome

Welcome to CST DESIGN STUDIO™, the powerful and easy-to-use schematic design tool built for the fast synthesis and optimization of complex systems. The tight integration with CST MICROWAVE STUDIO®, our electromagnetic field simulation software, and the integration of best-in-class solutions for circuit simulation, 2½D electromagnetic planar analysis and simulation using the mode matching technique from different vendors allow you to consider your system at different levels and take into account various effects.

CST DESIGN STUDIO™ is embedded into the CST DESIGN ENVIRONMENT™ that is referred to in the CST STUDIO SUITE™ Getting Started manual. The following explanations assume that you have already installed the software and familiarized yourself with the basic concepts of the user interface.

CST DESIGN STUDIO™’s schematic view can be accessed in two ways:

- The schematic view represents the main view of the stand-alone version. This view will initially be empty after a new project has been created. A circuit model can be set up in this view by adding and connecting components.
- Whenever CST MICROWAVE STUDIO® is used, the schematic view appears in addition to CST MICROWAVE STUDIO®’s main view. It always contains a component that represents the CST MICROWAVE STUDIO® project. This associated component can be connected with other components to construct a circuit.

After you have created a circuit model in the schematic view, only a few additional parameters need to be set before a simulation can be started. These steps are identical for both access modes described above. Note that the available components and simulation capabilities depend on the options purchased.

How to Get Started Quickly

We recommend that you proceed as follows:

- Read the CST STUDIO SUITE™ Getting Started manual.
- Work through this document carefully. It should provide you with all the basic information necessary to understand the advanced documentation.
- Please observe the “examples” folder in the installation directory. The different application types will provide you with a good impression of what has already been accomplished with the software. Please note that these examples are designed to give you a basic insight into a particular application domain. Real world applications are typically much more complex and harder to understand if you are not familiar with the device.
• Start with your own first example. Choose a reasonably small and simple circuit that will allow you to quickly become familiar with the software.

• After you have worked through your first example, contact technical support to obtain hints for possible improvements to optimize your usage of CST DESIGN STUDIO™.

What is CST DESIGN STUDIO™?

CST DESIGN STUDIO™ is a schematic design tool to create, simulate and optimize circuit models. These circuit models can be constructed with components available from different libraries. Such components implement physical behaviors that can be based either on analytical models, simulation results or measured data.

CST DESIGN STUDIO™ offers several simulation methods that are each associated with a specific set of results. The simulation settings are stored in so-called simulation tasks. Because you can maintain an arbitrary number of simulation tasks, you are able to run a sequence of calculations with different settings.

One of the most outstanding features provided by CST DESIGN STUDIO™ is its global parameterization that allows you to modify an arbitrary number of components within your circuit model by changing a single parameter. With the parameter sweep or optimization tools, the values for the given set of parameters can be improved step-by-step, according to predefined or custom-made criteria.

Among its main applications, CST DESIGN STUDIO™ enables the efficient design of complex and highly resonant structures. Splitting the complex system into smaller elements, each described by its S-matrix, allows the behavior of the complete system to be analyzed by combining results obtained from smaller segments. Consequently, the simulation time is significantly reduced.

Main applications for CST DESIGN STUDIO™

Most applications for CST DESIGN STUDIO™ will take advantage of the tight integration of CST MICROWAVE STUDIO® and the seamless workflow between a circuit simulator and a full 3D electromagnetic field simulator. There are two groups of applications we will distinguish between:

• High frequency circuit designs, where electromagnetic field effects need to be taken into account. In such cases, simple circuit models are not sufficient because they do not consider effects like cross-talk, etc.

• 3D electromagnetic devices where small circuits are embedded. Here, a circuit/EM co-simulation is needed. The co-simulation can either save simulation time or provide new opportunities, such as the definition of a specific excitation through a matching network.

Users of CST DESIGN STUDIO™ deal with very different devices. The range of applications includes microstrip filters, waveguide filters and multiplexers, antenna matching networks, etc.
CST DESIGN STUDIO™ Key Features

The following list provides an overview of CST DESIGN STUDIO™’s main features. Please note that all options may not be available to you due to license restrictions. Please contact your sales office for details.

User Interface

- Easy insertion and connection of components by drag’n’drop operation
- Convenient and intuitive handling of components inside a schematic view
- Layout view created from the unique database and simultaneously updated after structural modifications

Components

- Several analytical components
- Availability of circuit elements
- Provision of semiconductor model library
- Support of hierarchical modeling, i.e. separation of a system in logical components
- Tight integration with 3D electromagnetic field simulations from CST MICROWAVE STUDIO®
- Integration of simulation using the mode matching technique from Mician μWave Wizard™
- Integration of high frequency planar analysis from the Sonnet em® suite
- Import of net lists from Berkeley SPICE
- Support of the IBIS data file format
- Import of measured or simulated data in TOUCHSTONE file format
- Control and usage of extensible element library

Analysis

- Global parameterization
- Parameter sweep with an arbitrary number of parameters
- Optimization for an arbitrary number of parameters and a combination of weighted goals
- Tuning parameters by moving sliders and immediately updating the results
- Circuit simulation capabilities in frequency and time domains
- Time domain circuit simulation supports easy creation of eye-diagrams and signal port definition to make possible comparisons with results from simulations within CST MICROWAVE STUDIO®
- Built-in APLAC® for CST DESIGN STUDIO™ circuit simulator for linear and nonlinear simulation purposes in frequency domain
- Optional link to full APLAC® functionality

1 μWave Wizard is a registered trademark of Mician GmbH.
2 Sonnet em is a registered trademark of Sonnet Software, Inc.
3 APLAC is a registered trademark of APLAC Solutions Corp.
4 APLAC® for CST DESIGN STUDIO™ is a subset of APLAC® Simulator, APLAC Solutions’ Circuit Simulation and Design Tool, featuring a selection of linear and nonlinear elements and methods geared for EM / Circuit co-simulation tasks.
Easy definition of simulation tasks, some related to special devices such as mixers, amplifiers, or antennas

Automatic (re-)calculation of results from integrated field simulators

Recombination of fields in CST MICROWAVE STUDIO® for stimulations defined in CST DESIGN STUDIO™

Accelerated simulations by interpolation for simulated blocks

Solver transparency that allows selection of analytic or numerical evaluation of some components

Elimination of some components’ effects by de-embedding

Enabling of all kinds of circuit/EM co-simulations by using differential ports

Consideration of higher order modes

SPICE model extraction

Template-based post-processing

Result Management

Extraction of task-related results during simulation

Transparent access of result data via container scheme

Possibility of keeping and comparing results in user-defined containers

Visualization

Container data views and single data views of all results available

Several view options (real part, imaginary part, magnitude, polar plot, smith chart)

Measurement functionality inside the views (axis markers, curve markers)

Documentation

Creation and insertion of text boxes and images inside the drawing for documentation purposes

Annotations inside the data views

Automation

Powerful VBA (Visual Basic for Applications) compatible macro language including editor and macro debugger

OLE automation for seamless integration into the Windows environment
About This Manual

This manual is primarily designed to enable a quick start to CST DESIGN STUDIO™. It is not intended as a complete reference guide to all available features, but rather as an overview of the key concepts. Understanding these concepts will allow you to learn the software efficiently with help of the online documentation.

The main part of the manual is a Quick Tour (Chapter 2) that will guide you through the most important features of CST DESIGN STUDIO™. We strongly recommend that you study this chapter carefully.

Document Conventions

- Commands that are accessed through the main window are printed as follows: menu bar item → menu item. This notation indicates that you should first press the "menu bar item" (e.g. "File") and then select the corresponding "menu item" from the opening menu (e.g. "Open").

- Buttons that should be pressed within dialog boxes are always written in italics, e.g. OK.

- Key combinations are always joined with a plus (+) sign. Ctrl+S, for example, means that you should hold down the "Ctrl" key while pressing the "S" key.

Your Feedback

We are constantly striving to improve the quality of our software documentation. If you have any comments on the documentation, please send them to support@cst.com.
Chapter 2 — Quick Tour

CST DESIGN STUDIO™ is designed for ease of use. However, to get started quickly you will need to know a few key details. The main purpose of this chapter is to provide an overview of the software’s capabilities. Please read this chapter carefully, as this may be the fastest way to learn to use the software efficiently.

This chapter comprises the following sections:

- Overview of the User Interface’s Structure
- Creating a system
- Defining simulation tasks and running a calculation
- Dealing with parameters
- Performing a parameter sweep and an optimization

The following explanations are useful for users of CST DESIGN STUDIO™’s stand-alone version as well as for users of CST MICROWAVE STUDIO®. Both tools offer a schematic view where a circuit model can be constructed. The simulation setup is also identical for both versions.

The only difference between the schematic main view of the stand-alone version and the schematic view of a CST MICROWAVE STUDIO® project is the presence of a predefined ‘block’ inside the latter one. This block is associated with the CST MICROWAVE STUDIO® project (see topics below for additional information).

Overview of the User Interface’s Structure

Before we guide you through your first example, we will first explain the interface and its main components. We will do this by means of CST MICROWAVE STUDIO®’s design view because it contains additional elements that need to be explained.

If you are using CST DESIGN STUDIO™, you will see a main window similar to the one shown below immediately after you have started the program. If you are using CST MICROWAVE STUDIO®, you will need to switch to the ‘CST DESIGN STUDIO™ view’. Please observe the two ‘tabs’ within the main view:

Please click on the CST DESIGN STUDIO™ view tab now.
As you can see, the interface is mainly divided into five sub-windows:

- The **main view** is, in fact, a container that holds child windows with different views. Each child window can visualize the project or any available result. In the above example there are already two child windows: The CST MICROWAVE STUDIO® view and the CST DESIGN STUDIO™ view. If the views are maximized, they may be selected by the already mentioned view tabs. The contents of any view can be controlled through the **navigation tree**.

- All results and structural details can be accessed through the **navigation tree**. It is organized in folders and subfolders with specific contents. When you select an item from the tree, the currently active view will try to visualize its content in an appropriate manner.

- The **parameter window** shows all parameters that are currently defined. These parameters may be either globally defined parameters or local parameters of a selected 'block'.

- Whenever the program has information for you it will print this text into the **message window**. It may contain general information, warnings, or errors.

- The **block selection pane** can be thought of as a library of all elements that are available for creating a design and setting up a simulation. An element may be a circuit element like a resistor or a capacitor, a microwave element, a link to an external simulator, measured S-Parameters, or many other possibilities.
All windows, with the exception of the main view, are freely configurable. You may set them to your favored position. Furthermore, they may be docked (as shown in the picture above) or removed from the main frame, such that they become a standalone window. The standalone parameter window, for example, would look as follows:

The next noteworthy element is the status bar. The status bar primarily lists the currently selected global units. If a solver is running, some progress information will be displayed, as well.

The other elements to be mentioned are quite common to all windows programs. The main menu and the toolbars offer access to the functions of the program. Where the main menu tries to offer access points to nearly every function of the program, the aim of the toolbars is to give quick access to frequently used functions. Therefore, not every function may have a corresponding toolbar button. Also, quick access to functions is offered in context menus. The function types offered in the context menu depend on the current selection (a window, block or other program elements) and on the current program status.

Creating a System

This section will lead you through a simple example of creating a design, i.e. you will learn how to add components to your design and electrically connect them. Furthermore, this section will demonstrate how to modify the components' properties and use parameters.

There are several types of components available that can be categorized as follows:

- The blocks implement the physical behavior of a sub-system or represent a lumped circuit element. We distinguish between analytical, measured, and simulated blocks. Most of the available blocks are analytical blocks whose physical behaviors are described by parameterized circuit models or mathematical formulas. To consider measurement results, CST DESIGN STUDIO™ offers the Touchstone block that imports S-Parameters in the well-known Touchstone format. Other blocks, the so-called 'simulated blocks', reference or store projects of e.g. CST MICROWAVE STUDIO®, our 3D electromagnetic simulation software, Mician μWave Wizard™, a simulation tool using the mode matching technique -, or the Sonnet em® suite - a high-frequency planar EM analysis software. These blocks keep track of the projects’ results and even allow parametric control of the projects from within CST DESIGN STUDIO™. All blocks whose properties can be controlled by free parameters will also be called ‘parameterized blocks’. Furthermore, there are some special blocks such as the ‘Ground’ element that marks the common ground of a circuit. The CST DESIGN STUDIO block represents a placeholder for a sub-system and therefore supports hierarchical
designs. Finally, reference blocks define a common property set that can be assigned to analytical blocks. Reference blocks themselves show no physical behavior. All these blocks are discussed in more detail in the online documentation.

- The external ports represent sources or sinks of your system, e.g. for S-parameter simulations. In the case of simple circuit simulation tasks (where voltage sources or current sources are defined as excitations), the presence of external ports is not required. For these tasks, an external port will be replaced by a resistor to ground (or connected to the reference pin if the external port is differential) with the fixed port resistance specified (or 50 Ω if no fixed port resistance is defined).
- The probes can be associated with the links between the components. They record voltages and currents for the simple circuit simulation tasks.

To obtain a valid design, the inserted components must be properly linked by connection lines.

Adding and Connecting Components

Now it is time to simulate your first circuit in CST DESIGN STUDIO™. A simple band pass filter will serve as an example in the following sections. It consists of simple inductors and capacitors that form three resonating elements (LC sections) in so-called pi configuration. The filter’s topology is shown below.

Let us begin the circuit’s setup by inserting the first inductor. Select the Circuit Basic section in the block selection pane and press the left mouse button over this type of block. Keep the button pressed, move to the location inside the design view where you want to insert the block, and release the button to finish the insertion. During movement inside the design view, a template of the component is displayed for better orientation. As shown below, the inserted block is selected and can be moved inside the design view.

Please note that a tree item has also been added to the ‘Blocks’ folder of the navigation tree. A block tree item is named after the block that it belongs to. An inductor block’s default name is INDn and therefore the added block is called ‘IND1’ unless its name is changed by the user.
A block tree item may itself contain items. Its sub-items allow the access of block-related results. We will refer to these items later.

A block contains a certain number of pins (internal ports) according to the physical behavior attributed to it. Such an internal port is represented by a short line adjacent to the block. If it is not connected, this line is drawn in red, otherwise it is blue. Each internal port is labeled with a port number (except for lumped circuit elements, because these are sufficiently described by their block images representing them inside the design view). For example, the inserted inductor block has two internal ports whose lines are both red because they are not yet connected.

To insert the first capacitor, move the mouse over the left internal port of that block inside the block selection pane. When this internal port is highlighted by a red circle, press the left mouse button and drag the capacitor towards the right internal port of the previously added inductor. When the two internal ports contact each other, a red circle is displayed.

Release the mouse button when the red circle appears. As a result, the capacitor will be inserted and connected with the inductor. A valid connection is indicated by the short lines attached to the internal ports becoming blue.

You may also manually create a link between two elements. Therefore, place the next inductor by drag’n’drop to the capacitor’s right.

Now move the mouse pointer on the left internal port of the right inductor. As soon as the mouse pointer reaches the vicinity of that port it will be highlighted by a red circle and the mouse pointer icon will change to a bordered cross.
To define the starting point of the link, double-click on the red circle. The mouse pointer icon changes again and a rubber band line is drawn from the internal port to the actual mouse position.

Whenever your mouse pointer meets an element to which the link can be attached, the element will be highlighted and the mouse pointer icon will change back to the bordered cross. Click on the right internal port of the capacitor to finish the link. As soon as the link is created it will be drawn as a blue line between the two connected elements.

Please note that a link has no physical properties, i.e. there is no length associated with a link. A link only combines two interfaces (i.e. internal ports).

Now, insert another capacitor into your model. Place it to the left of the already inserted components and connect it as shown below:

Now rotate the left capacitor and the right inductor by selecting them one after the other and choosing View → Tools → Rotate/Flip Tools → Rotate Left/Right from the main menu or using the shortcut l or r (for left or right). Reposition these two blocks to obtain the following model:

To this point, an internal port was connected to exactly one other internal port. We always obtained a one-to-one assignment. However, circuits often have T-junctions and cross-junctions. In CST DESIGN STUDIO™, these junctions are realized by inserting nodes that can be connected to an arbitrary number of internal ports (or other nodes). Such a node is automatically created when you drop a selected internal port on a highlighted connection line instead of on another internal port, or when you click on a link while the link mode is active. Furthermore, if an internal port of an element is placed on a connection line, the element will be automatically positioned perpendicular to the connection line in a direction such that the element is moved toward it.
Try this behavior with the next element. Select another capacitor and move it to the design. Initially, it will be horizontally aligned. Now click on an internal port of the capacitor in the block selection pane and, in the main window, advance the capacitor from the bottom to the rightmost horizontal connection line. The element will automatically flip to a vertical orientation, such that the element remains below the horizontal line.

Release the element such that a node will be established. Insert the last inductor and rotate or move the elements until your schematic appears as below:

Finally, you need to connect all open internal ports with ground blocks. You find the ground block in the Circuit Basic section in the block selection pane. However, the fastest method of establishing ground connections is to use the shortcut $g$ when the design view is active (you may need to single-click into the design view in order to activate it). The shortcut $g$ (for ground) creates a ground block with the next mouse click. Try this feature now. After you have pressed $g$ you may notice the mouse icon change to a general insertion icon. Additionally, the same connection highlighting mechanism is activated as for the common drag’n’drop operations.

Click on the rightmost open internal port and the ground element will be created. Repeat this procedure using the shortcut $g$ with the remaining open internal ports.
External ports define sources and sinks of a design. Except for some circuit simulation tasks where voltage and current sources are used for excitation, external ports are required to perform a calculation. This is especially true for S-parameter calculations.

An external port may be inserted by the same drag’n’drop procedure as for a block. You find the port component in the Miscellaneous section of the block selection pane. Alternatively, you may take advantage of the shortcut p (for port) that works very similarly to the previously introduced shortcut g. Press p and click inside the main view to create the first port at your current mouse pointer position. Create a second port in the same manner and locate the ports as in the picture below. Note that ports are automatically numbered sequentially, starting at one. However, port numbers can be changed by the user as will be explained later.

The connection of an external port to an internal port or a node is established in the same way as the manual connection of two blocks: Perform a double click on the external port No. 1 and afterwards single-click on the edge of the connection line to its right. Do the same for the external port No. 2.
Now, all ports should be linked. Please make sure that there are no red lines in your design view that would indicate unconnected blocks. If necessary, repeat one of the actions explained above to establish the missing connection.

Note that nodes and edges of connection lines can also be moved to different locations. For more complex circuits it may sometimes be useful to modify the automatic layout.

**Changing Properties of a Block**

After creating the circuit’s topology we want to assign the values for C1, C2, L1 and L2 to the blocks’ corresponding properties. This is most easily accomplished by selecting a block and editing its properties in the docked parameter window shown below:

The contents of the list depend on the block’s type. The properties’ names should clearly reflect the physical property to which they belong. However, if there are some doubts about the meaning of a property, the online help will provide more information.

To edit the value for ‘Inductance’, perform a double-click in the ‘Value’ column of the ‘Inductance’ row. You may also choose a different unit within the selector box in the ‘Unit’ column. However, for our example, keep the default units.

Select the blocks one after the other and specify the following values:

<table>
<thead>
<tr>
<th>Element Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>L1</td>
<td>1.6 nH</td>
</tr>
<tr>
<td>L2</td>
<td>44 nH</td>
</tr>
<tr>
<td>C1</td>
<td>35 pF</td>
</tr>
<tr>
<td>C2</td>
<td>1.2 pF</td>
</tr>
</tbody>
</table>

Now your model should look similar to the picture below. Please make sure that all values have been set correctly.
An alternative method of changing the properties of a block is to open the block property dialog box by selecting the block and choose Edit\rightarrow Properties from the menu bar or using the block’s context menu in the design view or in the navigation tree. Furthermore, the block property dialog box can be accessed by pressing the ‘Properties’ button in the ‘View Tools’ toolbar (that is marked in the image below) or by double-clicking on a block inside the design view.

Now open the block property dialog box of the leftmost inductor. The dialog box generally consists of several sheets whose appearance may differ depending on the type of the selected block. In particular, the blocks that reference a file show some important differences that are referred to in one of the following sections.

The initially active page for parameterized blocks is labeled ‘Parameters’. It contains the list of properties that is also displayed by the docked parameter list control. Furthermore, there is a check button Show parameter table inside drawing to enable or disable the display of the parameter list inside the design view. By default, it is disabled.

You can edit a value associated with a parameter after clicking on it. If you enter an invalid value, an error message will be displayed. Furthermore, you can select units for some parameters. By default, these parameters are associated with the global units set for the project (we will refer to those settings later). The modification of a parameter is not stored until either the Apply button or the OK button is pressed.

Changing Properties of an External Port

To modify the properties of an external port, open the corresponding property dialog box by selecting an external port and choosing Edit\rightarrow Properties from the menu bar, or by double-clicking on the external port inside the design view. This dialog box is very similar to the block properties dialog box explained in the previous section.
The port property dialog box contains three pages labeled ‘General’, ‘Font’ and ‘Position and Size’. The ‘Font’ page and the ‘Position and Size’ page are identical to those of the block properties dialog box described above.

The ‘General’ page displays the port number that can be modified within this dialog box. Note that only positive integer numbers are valid. Additionally, there are three frames:

- The Mode frame provides the labeling of the external port with a mode number. If you check the Higher order mode box the external port’s name will be expanded to p(n), where p is the port number and n the number specified in the Number field.

- The characteristic impedance is an important property of an external port. The Impedance frame sets how this impedance will be determined. If the Fixed impedance radio button is disabled (which is the default) the impedance will be set according to the specific impedance of the attached block. However, some blocks do not have a characteristic impedance (such as circuit elements like capacitors or inductors). In these cases, the impedance must be set manually. If it has not been set, the external port’s impedance will be automatically set to the default value of 50 Ω and the message window will display a message. If the Fixed impedance radio button is enabled and a value different than that of the attached block is entered, the block’s S-Parameters will be internally renormalized.

- By default, the common ground (that does not need to be explicitly defined, but can also be a point at infinity) represents the reference node for an external port. For circuit simulations, you might want to define a differential port that refers to a node inside your circuit. In this case, switch on the Differential property inside the General frame. The external port will be expanded by a pin (as shown to the right) to which you can connect the reference node.

Let us return to our example of a band pass filter. Because the input and output impedances must be set to $Z_0 = 50 \, \Omega$, we will switch on the Fixed Impedance property and keep the default value of 50 in the Impedance field as shown below.
Performing a Simulation

This section will demonstrate how to generate the results that you are interested in. Therefore, global settings are explained and a “simulation task” is defined.

Unit Settings

To this point, we have assigned some values to the element’s properties and decided to keep their association with the global project units. Therefore, if you change the global inductance unit from nH to uH, you scale all inductances referring to the global unit by a factor of 1000, because the values assigned to the properties are retained. To avoid this scaling you may select local units for each block.

The global units are displayed in the status bar. They can be modified within the ‘Units’ dialog box. To open it, choose Simulation>Units from the main menu or press the corresponding button in the ‘Design Tools’ toolbar (see below).
The Units dialog box shows the selection of the global units currently applied to your project.

For our example, all inductances are given in nH and all capacitances are given in pF, which are the default settings for ‘Inductance’ and ‘Capacitance’ properties. We do not need to perform any modification and can therefore leave the dialog box by pressing the Cancel button.

Defining Simulation Tasks

In order to obtain information about the filter’s characteristics, we intend to calculate the S-parameters for our design. The S-parameter calculation is a simulation task that can be performed within CST DESIGN STUDIO™. Moreover, CST DESIGN STUDIO™ offers several circuit simulation tasks that are explained in detail in the online documentation.

To define a new task, open the ‘Select Simulation Task’ dialog box by pressing the button that is marked in the image below.

Alternatively, you may choose Simulation → New Task from the main menu.
The ‘Select Simulation Task’ dialog box provides the selection of the new task. The ‘Details’ frame displays some information about the selected task.

Depending on the selected task, another dialog box will be opened (after pressing the OK button) in which you can define the specific settings. An overview of the available simulation tasks is given in the online documentation.

Select ‘Standard→S-Parameters’ and press the OK button. The ‘S-Parameter Simulation Task’ dialog box will be opened where you can input S-parameter-specific settings.
The dialog box shows five frames:

- Inside the *Frequency Limits* frame, the largest frequency range for which the model is valid is displayed. If your model does not contain any frequency-bounded blocks, ‘None’ is displayed for the lower and upper limits. Otherwise, the range represents the intersection of all block ranges.
- Inside the *Units* frame you may select the frequency unit that all task properties refer to. By default, the global frequency unit is set there, but you can also choose a local unit that is different from the global unit.
- The *Circuit Simulator* frame only concerns S-parameter calculations for circuit models. Depending on the options licensed, different simulators may be available and can be chosen here.
- Inside the *S-Parameter Settings* frame the frequency range for the S-parameter calculation and the number of frequency samples are specified. There is a check box labeled *Maximum frequency range*. If this property is switched on, the maximum valid frequency range will be used for the simulation. Note that frequency bounds must be shown in the *Frequency Limits* frame if you choose this option. If there is a valid frequency range, this option is switched on by default. In addition to this control, there are three edit fields: The *Fmin* and *Fmax* fields are only editable if the *Maximum frequency range* option is switched off. There, you can enter values that must be within the range given by *Lower limit* and *Upper limit*. Finally, you should specify the number of frequency samples to consider in the *Number of frequency steps* edit field. You may also choose the *Logarithmic sweep* option to perform a logarithmic sweep instead of a linear sweep inside the specified frequency range.
• Inside the **Individual Blocks** frame you may choose to store the S-parameter results for the individual blocks that are calculated while the simulation task is running. Depending on the number of blocks that your model contains, this option may slow down the simulation significantly. Furthermore, you can choose the interpolation scheme for the imported blocks’ data here. The selection of **Real/Imaginary** may lead to small inaccuracies for the amplitude and phase and vice versa.

There is another tab labeled ‘Combine Results’ that allows additional settings for antenna calculations. We will describe the use of those settings later.

As the frequency range of interest we choose $400 \leq f / \text{MHz} \leq 1000$ and keep the default value of 101 for **Number of frequency steps** as shown above. Press OK to confirm your settings and add the S-parameter simulation task to your project.

The item ‘S-Parameters1’ is added to the ‘Tasks’ folder inside the navigation tree as shown below.

Double-clicking on it reopens the ‘S-Parameter Simulation Task’ dialog box where you can modify the settings for this task. You can also rename or delete it using the item’s context menu.

You can add an arbitrary number of tasks to your project. Each task can be accessed from the navigation tree. If you invoke an update of the results for your design, all simulation tasks will be performed one after the other. If you want to exclude a task from the update loop but do not wish to delete it, you can simply disable it. Therefore, open the tree item’s context menu by right-clicking the corresponding task’s item and choosing **Disable**. To re-enable it, carry out the same procedure choosing **Enable** instead.
Starting a Simulation

After all required settings have been established, a calculation of the S-parameters according to the defined task can be performed. Choose Simulation ➔ Update from the main menu or press the Update button in the ‘Design Tools’ toolbar. Update can also be performed using the shortcut F5.

As mentioned above, all simulation tasks are executed one after the other during an update operation. You should examine the message window where information about the simulation progress is displayed in addition to warnings and error messages. For our example, just two lines are displayed indicating the beginning and the end of the execution of the task:

Visualized of the Results

This section will introduce the result views that can be accessed from inside the navigation tree. We distinguish standard result views that are automatically generated by CST DESIGN STUDIO™ from user-defined result views that are added by the user. In the user-defined result views, single results of the current result set can be inserted.

Standard Result Views

CST DESIGN STUDIO™ automatically generates views of the results associated with the executed simulation tasks. For instance, for the S-parameter simulation task, result views are added that show S-parameters and impedances as a function of the frequency for the complete design. These result plots can be activated by clicking on their associated items inside the navigation tree.
Each of these tree items is itself a folder. Inside these folders are tree items that are related to the single curves of e.g. the S-parameters view.

To display a view that contains such a single data set, click on one of these items.

In the following section, we will often refer to ‘owners’, ‘containers’ and ‘data’. These terms are related to the organization of result view items inside the navigation tree. ‘Data’ is associated with a data set, i.e. with a single curve, e.g. ‘S1,1’. A single data set is always encapsulated in a data ‘container’, e.g. the ‘S-Parameters’ container. Displaying a container’s contents means showing its data altogether. Finally, a container is owned either by a single block, by the design, or by a probe, depending on the type of result. Examine the container’s parent folder inside the navigation tree to determine the owner. Note also that a container is always indexed by the simulation task that it is based on inside the navigation tree. Because the simulation task named ‘S-Parameters1’ was run, this name in brackets is added to the containers’ tree items.

To open the S-parameter view of the complete design, click on the ‘S-Parameters [S-Parameters1]’ item related to the design:

Initially, a result view shows the container’s (or data’s) magnitude. In order to switch to another representation, use the ‘Plot Tools’ toolbar shown below. These options are also available via View⇒Type.
In fact, our model represents a band pass filter. A better idea of its performance is given by the ‘Magnitude in dB’ representation. Switch to ‘Magnitude in dB’ to obtain the following plot:

Initially, the ‘Zoom’ mode is active: You can define a zoom rectangle by clicking inside the view, keeping the mouse button pressed, moving the cursor to a different location and releasing the button. Immediately after releasing the button, a more detailed view will be displayed. There are additional modes that can be activated via View→Mode or using the ‘Plot Tools’ toolbar:
In addition to the modes, there are some view options available through View. The associated toolbar buttons are shown below:

- Show axis marker
- Show curve markers
- Show measure lines
- Show annotations

To navigate inside a zoomed view, activate the ‘Pan’ mode. It allows you to move the view in vertical and horizontal directions.

Axis marker, measure lines and curve markers are tools for performing measurements inside a plot view. The following information can be obtained using these tools:

- The axis marker is a vertical line that is initially located in the middle of the x-axis. Its current x-value and the y-values of the intersections of the axis marker and the curves are displayed. Thus you can retrieve the position of a pole, for instance.

- The measure lines are two pairs of lines, one pair in parallel to the x-axis and one pair parallel to the y-axis. The difference between the values of each pair is displayed as well as the measure lines’ current x-values or y-values, respectively. Thus you can retrieve the minimum and the maximum value of a curve and the distance between them, for instance.

To demonstrate how measure lines can be utilized, let us assume that we would like to have a filter characteristic for our band pass filter as follows:

<table>
<thead>
<tr>
<th>Description</th>
<th>Frequency range</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop band</td>
<td>400 &lt; f / MHz &lt; 550</td>
<td></td>
</tr>
<tr>
<td>Transition region</td>
<td>550 &lt; f / MHz &lt; 610</td>
<td>-</td>
</tr>
<tr>
<td>Pass band</td>
<td>610 &lt; f / MHz &lt; 790</td>
<td></td>
</tr>
<tr>
<td>Transition region</td>
<td>790 &lt; f / MHz &lt; 850</td>
<td>-</td>
</tr>
<tr>
<td>Stop band</td>
<td>850 &lt; f / MHz &lt; 1000</td>
<td></td>
</tr>
</tbody>
</table>

The frequency range of the pass band can be represented within the plot using the measure lines very easily. Switch them on by choosing View -> Measure Lines from the main menu. Move one of the vertical lines to 610 MHz by clicking on it and dragging it to the desired position while keeping the mouse button pressed. The current position of the axis marker will be plotted below the frequency axis. In the same manner, move the other one to 790 MHz to have a visualization of the pass band for our filter.

Now we can check the performance of our current filter design within the pass band. Move one of the horizontal lines to the maximum |S11| value in the range of the pass band. The maximum value is plotted left of the measure line.
As you can see, the worst case pass band performance is about -4.5 db. The curves suggest that an overall minimum of S11 within the pass band has not yet been reached.

To move an axis marker or a measure line to a certain location, you may also double-click over it to open the following dialog box where you can specify the desired position:

In a subsequent section we will demonstrate how to optimize our filter design. We will introduce parameters, study their influence by performing a parameter sweep and finally optimize the filter using the built-in optimizer tool.

But first, let us return to the visualization subject. The following sections will teach you how to modify the plot’s properties. Furthermore, we will show you how to create user-defined result views and add data there.

Customizing Result View Properties

In addition to the buttons used to switch between the visualization types and interaction modes, the ‘Plot Tools’ toolbar contains two additional options:

- Pressing the ‘Plot Properties’ toolbar button or choosing View⇒Plot Properties from the main menu, or using the plot’s context menu item Plot Properties activates the ‘Plot Properties’ dialog box.
• Selecting ‘New Plot Window’ opens another plot view, initially displaying the same contents as the current one, but in ‘Magnitude’ representation. To switch between the plots you may click on the corresponding tab. Alternatively, you can use the context menu of the corresponding tree item: If it refers to more than one plot, it contains the entry Next to activate the next view. Note that the plots are organized in cyclic order: After you have activated the last one, choosing Next will activate the first view.

Let us now examine the ‘Plot Properties’ dialog box. The dialog box contains four frames:

- **X Axis** frame:
  - If Auto scale is chosen, the plot’s minimum and maximum abscissa values are automatically calculated. To specify your own values, switch off this option and edit the Min and Max fields.
  - The Round option expands the plot range to the next rounded minimum and maximum abscissa values. This option is only available if Auto scale is set.
  - Ticks subdivide an axis into intervals of identical size. Switch on Auto tick for an automatic calculation of an interval’s width. To specify your own tick width, switch off this option and specify Tick.
  - Choose the Logarithmic option to establish a logarithmic axis. A logarithmic axis does not allow customized ticks.

- **Y Axis** frame:
  - The settings described for the x-axis can be applied to the y-axis. There is a further option, Wrap phase, that limits the display of a phase to \(-180^\circ < \text{arg} < 180^\circ\).

- **Curve style** frame:
  - Within the X Axis frame you can customize the range and appearance of the x-axis and the positions of the horizontal ticks:
    - Additional marks
    - Marks only

- **Font** frame:
  - Within the Curve style frame you can switch on/off colors and additional marks for all curves or you can choose a representation containing only marks instead of lines.
Within the Font frame you can specify the font for the title, axis labels, etc.

To exclude some curves from the current plot view, choose ViewÆSelect Curves from the main menu or choose Select Curves from the view’s context menu.

The ‘Select Curves’ dialog box will be opened then that consists of two list boxes: The box labeled Hidden Curves shows a list of the curves that are currently not displayed and the box Displayed Curves contains the curves that are currently displayed. Use the buttons > and < to move entries from one list box to the other or press All or None to move all entries to one of the boxes. Pressing OK or Apply applies the selection to the plot.

User-Defined Result Views

In addition to the standard result views that are automatically generated, a user-defined result plot can also be created:

Select the ‘Results’ item inside the navigation tree and choose ResultsÆAdd User Result Plot from the main menu or choose Add User Result Plot from the item’s context menu that can be activated by pressing the right mouse button. A tree item is added to the folder with an editable label. This tree item represents a new container. You may enter a name for your result container or accept the default name ‘Result’.

Click over this new tree item to activate the container’s view. Since the container is initially empty, the view only displays the message ‘Result not available’. To add data to the new result container, choose Add Result Data from the item’s context menu. The ‘Add Result Data’ dialog box is opened then where you can specify a data set.

Data from the existing result set can be addressed by its location inside the navigation tree that is reflected by the owner/container/data scheme introduced earlier. For instance, to add the transmission factor $S_{21}$ of the complete design to the user-defined result plot, choose ‘Design’ for Owner, ‘S-Parameters [S-Parameters1]’ for Container
and ‘S1,1’ for Data, as shown below. Furthermore, specify a label that will be assigned to the selected curve inside this plot, e.g. ‘Initial S11’.

![Add Result Data](image)

Press the OK button and the selected curve will been added to the container.

![Container Tree](image)

The current view is related to the container and displays the inserted data. As described for the standard result views above, the container tree item is itself a folder that contains the items of data from where you can access the views of the data curves.

![Result Magnitude](image)

**Parameterization and Optimization**

The parameterization of a design enables you to easily consider variations. If properties are associated with parameters, the properties can be changed and therefore influence the design’s behavior. In the following section, the use of parameters will be shown and a parameter sweep will be performed. However, a common application of parameters is their optimization with respect to goal functions that will also be explained in this section.
Using Parameters

CST DESIGN STUDIO™ offers the possibility of dealing with global variables that may serve as parameters for global settings or block properties. Working with parameters is straightforward: First, you must define them inside the parameter list control; you may then assign them to a property (including mathematical expressions containing parameters).

The parameter list control displays a table consisting of four columns labeled ‘Name’, ‘Value’, ‘Description’, and ‘Type’. The table itself initially shows one single empty line (except for the ‘Type’ column displaying ‘Unknown’) as shown below. If you define a new parameter, it does not matter which column you edit first. The definition of a parameter is not completed until a name has been specified. However, we recommend that you start with the first column.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global</td>
<td></td>
<td></td>
<td>Undefined</td>
</tr>
</tbody>
</table>

Valid names are all strings that are valid variable names in VBA. In particular, they must not be interpreted as a VBA command and must not contain special characters such as spaces, etc. Valid values are all expressions consisting of mathematical VBA functions, real numbers and previously defined parameters. The specification of a description is optional. Within the ‘Type’ column you should specify the type of unit that a parameter is associated with. This information is only applied if the current design is used as a sub-model or if parameterized contents are copied to another model to properly scale the concerned properties. Moreover, the parameter list control provides the following features:

- A parameter can be removed from the list and will be deleted from your project, as well. Therefore, select the parameter row by clicking on any field in this row and choose Edit→Delete from the main menu or Delete from the context menu. If the selected parameter is used somewhere in your project the following message box will appear:

  ![Message Box]

  Pressing OK leads to the replacement of the selected parameter by its value everywhere it is in use.

- The name of a parameter inside the list is editable. Note that renaming a parameter means that it will be deleted and a new one will be defined. Therefore, renaming may also lead to the same message described above.

- To check whether a parameter is in use (and whether you can rename or delete it without any consequences, select it and choose Edit→Dependencies from the
main menu or Dependencies from the parameter list control's context menu. If it is used for any properties, a dialog box is opened containing a list of those properties. Otherwise, a simple message will be displayed, indicating that the parameter is not used.

- A parameter can be replaced by its value by choosing Edit→Replace by Value from the main menu or Replace parameter by value from its context menu. The parameter will then not be deleted.
- You can also search for a string inside the parameter list: Choosing Edit→Find from the main menu opens the following dialog box. Enter the search string and press the Find button.

For our example, we are going to introduce four parameters: C1, C2 (representing the capacitances of the capacitors) and L1, L2 (representing the inductances of the inductors). To start to define C1, click the left mouse button on the top left cell inside the parameter window that will then become editable. Enter the name ‘C1’ and press the Tab key to change to the ‘Value’ column or click the left mouse button over that cell. We recommend using the Tab key as it allows you to add your entries very quickly. The value 0 has been automatically assigned to the new parameter. The value can now be edited (after selecting it by mouse click or using the Tab key). Enter ‘35’ there and press Tab again to change to the ‘Description’ column where you can optionally give a short description of the parameter. If you press Tab again, a new row will be added to the table and its ‘Name’ cell will be selected and editable. Continue as described for all parameters.

For the last step, do not forget to select the correct type for each parameter. In our case, this would be either ‘Capacitance’ or ‘Inductance’. After everything is set, the parameter list should look as follows:
Now, activate the design view (click on the ‘Drawing’ folder in the result tree or click on the tab with the CST DESIGN STUDIO™ icon) and select the leftmost inductor inside the design view. With the selection the parameter window will change and show the local parameters of the selected block. Replace the current value for the inductance with the previously defined parameter ‘L1’.

Instead of using the parameter window you could also have opened the inductor’s properties dialog box by choosing Edit ⇒ Properties and changed the parameter there.

Repeat this procedure for the remaining elements until your drawing looks like the below figure:

Note that the results are not removed from your project. This means that you still can access the result views from the navigation tree, but the tree items associated with them have changed to indicate that the results do not correspond to the current settings and that they need to be updated. Also, the plot views show a grey background to indicate that the results have not been updated.
To check our model once more and become more familiar with the parameter list control, single click into the design view to activate the global parameter list and click the right mouse button over the row belonging to the parameter C1. Then, choose Dependencies from the activated context menu. The following ‘Dependencies’ dialog box appears and displays the blocks and properties that depend on the selected parameter.

![Dependencies dialog box](image)

After closing this dialog box by pressing the OK button, press the F5 key to update the results. All standard result views are automatically generated that show the same contents as before.

Let us now modify the parameter C2. Click the left mouse button on its ‘Value’ cell and enter ‘1.4’ there.

![Parameter list](image)
Activate the design's S-parameter view now by clicking on the ‘S-Parameters [S-Parameter1]’ folder and change the plot to ‘Magnitude in dB’ representation by selecting the corresponding button in the ‘Plot Tools’ toolbar. Then, update the results (F5). The results are now calculated for the current parameters. After the calculation is completed, the ‘out of date’ result icons in the result tree are changed to the normal result view items. Of course, the S-parameter results have changed according to the parameter modification:

To continue, reset the parameter ‘C2’ back to 1.2 and update the results again.

Performing a Parameter Sweep

Because you have successfully introduced parameters, it might be interesting to see how the results change when these parameters are modified. The easiest way to obtain these variation results is to perform a parameter sweep.

Open the ‘Parameter Sweep’ dialog box by choosing Simulation ➔ Parameter Sweep from the main menu.
This dialog box consists of two sections:

- Within the left Sequences frame you can specify the parameters to sweep, the number of steps to perform, etc. It contains a list that displays the defined sequences and the parameter ranges assigned to the sweep. Furthermore, there are buttons to add and delete a sequence or a parameter, respectively.
- Within the right Result Watches frame you can specify which results you want to store during the sweep and where you want to store them. The reference to result data is defined as explained for the ‘Add Data’ dialog box in one of the previous sections. Please remember that result data is described by its owner, its container and its name. During the sweep, the selected result data will be added to the parameter sweep’s result container. You can either choose it from a list or enter a new name. In the latter case, the new container will be created during the parameter sweep.

Let us now perform a parameter sweep step-by-step. First, we create a new sweep sequence by pressing New Seq. A sequence ‘Sequence1’ is added to the list of sequences that is selected right after its creation, which causes the buttons New Par, Edit and Delete to become active.

Pressing the Edit button makes the name of the sequence editable. Clicking on the Delete button simply deletes the sequence.

Clicking on New Par opens the ‘Parameter Sweep Parameter’ dialog box where we can select a parameter and specify the range of values assigned to it during the sweep. Choose the parameter ‘C1’ as the first parameter to alter during the sweep.
Initially, you can just enter one value for the selected parameter that will be set during the sweep sequence. To specify a parameter range, check the ‘Sweep’ option. Now, enter 33 as the lower limit (From), 37 as the upper limit (To) and assign 4 to the Steps field as shown below.

Press OK to add the parameter variation to the sequence. The parameter variation is added to the sequence and is displayed in the sequences frame:

![Parameter Sweep Parameter dialog box](image)

CST DESIGN STUDIO™ is able to perform parameter sweeps with an arbitrary number of parameters. For demonstration purposes it is sufficient to consider only one parameter. If you define more than one parameter variation and assign it to a sequence, calculations for all combinations of the possible parameter values are performed during the parameter sweep.

As a second step, we must define a so-called watch that records the results of interest during the sweep. Therefore, a standard result container must be specified as a source and a user-defined result container as a target to insert the results. The target container does not need to exist at the beginning of the sweep, as a new one will be created if necessary.

We are going to record the return loss of the filter, so choose ‘Design’ as Owner, ‘S-Parameters [S-Parameter1]’ as Container and ‘S1,1’ as Data. We could add the results to our existing user-defined result plot ‘Result’, but we will create a new one by entering a name different from ‘Result’, e.g. ‘Sweep’, as shown below. Furthermore, we specify the curve’s name, e.g. ‘S11’. Press the Add button now. The watch list will be expanded by an entry describing the new watch.
Of course, you can also delete existing watches. To do so, select a watch and press the \textit{Delete} button inside the \textit{Result Watches} frame. The watch will be immediately removed from the list.

An existing watch can be replaced by another one by selecting it in the list, performing all the specifications described to add a new watch and finally pressing \textit{Replace} (instead of \textit{Add}).

Please note that all watches are updated after each individual calculation within the sweep, i.e. all watches are associated with all sequences and vice versa.

Please make sure that your entries in the ‘Parameter Sweep’ dialog box correspond to those shown in the figure below. Otherwise, delete the wrong parameter variation or watch and redefine it as explained above.
After successfully defining parameter variations and watches the **Start** and **Check** buttons of the ‘Parameter Sweep’ dialog box become active.

The values that will be assigned to the parameters during the parameter sweep might exceed the valid range of some of the associated properties. For example, the transmission lines' characteristic impedances must be greater than zero; a value less than zero would lead to an error. Clicking on **Check** performs a sequential update of the databases. If an update fails, a message will be displayed and you should modify your settings.

Please perform a check (which passes through for our settings) and start the sweep afterwards by pressing the **Start** button.

After the parameter sweep is complete, select the ‘Results\sweep\s11’ sub-item inside the navigation tree to view the results. The container's result view is then opened.
Performing an Optimization

CST DESIGN STUDIO™ offers a very powerful built-in optimization feature that is able to consider an arbitrary number of parameters and a combination of differently weighted goal functions.

In the following, we will optimize the characteristics of our band pass filter. The optimization goals for our filter will be as follows:
To achieve this goal, choose Simulation→Optimize from the main menu to open the Optimizer dialog box. The four pages of this dialog box contain all necessary settings for performing an optimization.

The initially displayed ‘Parameters’ page contains a list of all previously defined parameters that can be used for the optimization. For our example, the four parameters defined for the band pass model are displayed.
The list shows the optimization settings and properties for each parameter, namely, the parameter's minimum and maximum values, the number of samples, the initial value, the current value, and the best value that is the result of the last optimization process. Furthermore, to the left hand side of the parameters a column of check boxes is displayed, where you can select the parameters to use for the optimization.

Select C1, C2 and L1 to include them in the optimization process.

For the selected parameters you can specify the minimum and maximum values, the number of samples and, if the *Use current as initial values* option at the top of the list is switched off, the initial value. By default, this option is switched on to initialize each parameter by its current value.

The optimizer attempts to optimize a goal function by evaluating the goal function for different parameter sets. Because the evaluation of the goal function might be very expensive, the aim of every optimizer is to find the function's optimum with as few evaluations as possible. Therefore, our optimizer evaluates the goal function only at specific parameter values and uses an interpolation scheme for all other parameter values. This parameter sampling is defined by the given parameter range ("Min" and "Max" fields) and maximum number of samples ("Samples" field). These three settings should be chosen with care. The sampling rate may be too low to achieve sufficient accuracy for the interpolated goal functions or the calculation time might become too large, particularly if simulated blocks are contained in your model. Good compromises for many structures are the default settings of 5 samples for each parameter and a relative parameter range of 10% of the initial value.

The 10% parameter range can be defined in the edit field associated with the *Reset min/max* button on top of the parameter list. Clicking on this button automatically adjusts the range of the selected parameters: The entries in the 'Min' column are set to the initial values minus the specified percentage; the entries in the 'Max' column are set to the initial values plus the specified percentage.

In our example we have seen from the parameter sweep that the results are quite sensitive to parameter changes. Therefore lower the value to 5% and press 'Reset min/max' button to update the Min/Max values in the table. Finally, you may double-check your settings against the following picture:
Now, we need to specify the goal function for our optimization. Change to the ‘Goals’ page by clicking on the corresponding label at the top of the dialog box.

The ‘Goals’ page is quite similar to the ‘Parameters’ page, but it contains a list of goals instead of parameters. It is initially empty because no goal has yet been defined.

To add a new goal, select a type from the top left selector box. Usually, a type-specific dialog box is opened in which you can perform the relevant settings. An existing goal can be modified by selecting it inside the list and pressing the Edit button. A very similar dialog box then appears that allows modification of the goal settings.
You can also remove goals from your list. To remove a single goal, select it and press the Remove button. To remove all goals press the Remove All button.

Goals can also be disabled and kept for later use. To do so, use the check boxes that are associated with the goals.

CST DESIGN STUDIO™ offers two types of goals:

- The ‘Result Data’ goal refers to any standard result data that is automatically generated during execution of the enabled simulation tasks.
- The ‘User defined’ goal is specified in VBA language. Choosing ‘User defined’ from the top left selector box opens a macro editor window that already contains some basic macro input lines, which should be customized according to your needs. Please refer to the online macro documentation for details. After editing the goal function, do not forget to save the macro. During the optimization this macro will be executed after each update to determine the current goal function value. Because this feature is more advanced, we focus on the ‘Result Data’ goal in this documentation.

The selection of the ‘Result Data’ goal opens the ‘Define Goal’ dialog box that contains four frames:

- In the Type frame you can select whether you want to optimize the magnitude (Mag. (linear)), the magnitude in dB (Mag. (dB)) or the phase of the data (Phase).
- In the Data frame you may specify the data to optimize according to the already presented owner/container/data scheme. This section is similar to the ‘Add Data’ dialog box and the ‘Result Watch’ frame of the ‘Parameter Sweep’ dialog box.
In the **Conditions** frame you may assign an objective for the selected data. We will describe the proper definition of such a target in detail later on. Furthermore, you can specify a weight for the goal.

In the **Range** frame you can specify the abscissa interval (range) within which the condition should be satisfied. There are three options: You may either optimize at a single value (select **Single**), at a given abscissa range (select **Range**) or for the total abscissa range (select **Total**). The default option is **Total**. In many cases the abscissa values will be frequency values.

Let us take a closer look at the definition of a condition by considering some examples. Select **Mag. (dB)** and ‘S11’ (Owner=’Design’, Container=’S-Parameters [S-Parameters1]’ and Goal=’S11’) in the first two frames.

**Specifying constraints:**

- If you want the selected data not to exceed a certain value, perform the following settings: Choose the operator ‘<’ from the list shown on the right and specify the maximum value of chosen data and type inside the Target edit field. The Abscissa edit field will be disabled for this type of goal.
- For the specification of a lower data limit just select the operator ‘>’ and perform the same steps. The Abscissa edit field will be disabled for this type of goal.
- Use the operator ‘=’ to optimize the parameters such that the data value equals the target value. The Abscissa edit field will be disabled for this type of goal.

**Minimizing or maximizing the goal function:**

To minimize or maximize the goal function for a given range, simply select the operator ‘min’ or ‘max’, respectively. The Target edit field and the Abscissa edit field are not applicable here and are therefore disabled.

**Moving the minimum or maximum value to a specific abscissa value:**

To move the minimum or maximum value to a specific abscissa value, select the operator ‘move min’. The Target field will be ignored in this case, and is therefore disabled. Within the Abscissa edit field you can specify the target that the minimum should be moved to.

Because a value will be moved along the abscissa, the **Single** setting in the Range frame will be disabled for this type of goal. You can analogously move the maximum value to a certain location using the operator ‘move max’.

If there is more than one goal, you may adjust their influence on the optimization by specifying a weight. It can be any positive number.
For our example, we need to define three goals specifying constraints for certain ranges.

<table>
<thead>
<tr>
<th>Description</th>
<th>Frequency range</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop band</td>
<td>$400 &lt; f / MHz &lt; 550$</td>
<td>$</td>
</tr>
<tr>
<td>Transition region</td>
<td>$550 &lt; f / MHz &lt; 610$</td>
<td>-</td>
</tr>
<tr>
<td>Pass band</td>
<td>$610 &lt; f / MHz &lt; 790$</td>
<td>$</td>
</tr>
<tr>
<td>Transition region</td>
<td>$790 &lt; f / MHz &lt; 850$</td>
<td>-</td>
</tr>
<tr>
<td>Stop band</td>
<td>$850 &lt; f / MHz &lt; 1000$</td>
<td>$</td>
</tr>
</tbody>
</table>

The first goal definition should look as follows:
After all three goals have been defined, the ‘Goals’ page should look like this:

![Goals Page](image)

Additional settings can be performed in the ‘Specials’ page:

![Specials Page](image)

Here, the number of passes to perform can be specified. For each pass the optimizer will be restarted with a reduced parameter range that encloses the determined optimum. Furthermore, you can decide whether or not the goal function values are normalized: In general, the goal functions of the individual goals should yield approximately the same range of values (e.g. \([0\ldots1]\)). This is referred to as ‘normalization’. For our example, leave all settings at their defaults.
Now press the Start button. As soon as the optimizer is started, the solver run ‘Info’ page will be available, displaying some information about the optimization process. To visualize the optimization process, click on the S-parameter tree item.

When the calculations are performed, the ‘Info’ page reports the progress of the optimization. Among the values displayed are the number of evaluations (some of them are based on a calculation, while others are determined by interpolation of the calculated results), the first, the last and the best goal function value and the best parameter value thus far. During the first evaluations no values are assigned to the last four properties because the number of samples is still too small.

After successful completion of the optimization the ‘Info’ page displays the results as shown below:

During the optimization, the goal function value decreased from 2.60 to 2.45, indicating that the optimizer was able to improve the filter’s characteristic.

To compare the optimizer result with the initial result that was stored in the user-defined result container with the name ‘Result’, activate the context menu of the previously defined result item inside the navigation tree and choose Add Result Data. The ‘Add Data’ dialog box will then be opened. Specify the optimized data to be inserted into the container (Owner='Design', Container='S-Parameters [S-Parameters1]' and Data='S11') and enter ‘Opt S11’ as the new label. Then, press the OK button to leave the dialog box. The data curve will be added to the container’s result view. Let us take a look at its ‘Magnitude in dB’ representation: You can verify that the insertion loss throughout the pass band could be lowered by 2.6 dB.
Chapter 3 — Integration with CST MICROWAVE STUDIO®

This chapter provides an introduction to the integration of CST DESIGN STUDIO™ with CST MICROWAVE STUDIO® that allows for a straightforward coupling of EM simulation and circuit simulation.

Depending on which software you are using, CST DESIGN STUDIO™ or CST MICROWAVE STUDIO®, your view on the integration may be slightly different. That is why this chapter is divided into two sections:

- The first section mainly addresses users of CST MICROWAVE STUDIO® who are interested in quick access to the schematic view’s functionality and S-parameter simulation capabilities. In this case, the schematic view will only contain one single CST MICROWAVE STUDIO block representing the associated 3D model and some additional simple circuit elements, such as resistors, capacitors, etc.

- The second section explains features that are more common to users of CST DESIGN STUDIO™. It will deal with a design consisting of several CST MICROWAVE STUDIO blocks of the two different types available: the parameterized block and the file reference block.

Integration from the CST MICROWAVE STUDIO®’s User’s Point of View

For each CST MICROWAVE STUDIO® structure, two fundamentally different views on the model exist. The standard view is the 3D model representation which is visible by default. However, in addition, a schematic view can be activated by selecting the corresponding tab under the main view:
Once this view is activated, a schematic canvas is shown where the 3D structure is represented by a single block (MWS block) with terminals:

The terminals are a one-to-one correspondence to the 3D structure's waveguide or discrete ports. The schematic view now allows for easy addition of external circuit elements to the terminals of the 3D structure.

Adding circuit elements to the schematic view is straightforward. The general procedure is to select a circuit element from the block selection pane and drag it onto the schematic canvas.

The block selection pane is organized into several categories containing elements that may or may not be accessible to you according to license restrictions. Contact your sales office for more information.

Basic circuit elements such as R, L, C, GND and ports are normally included in the basic CST MICROWAVE STUDIO® license.

You can access the circuit elements from the block selection pane after clicking on the Circuit Basic tab:
These elements can now either be dragged by pressing the left mouse button on the element itself or even more easily by pressing the left mouse button while the cursor is on one of the element’s terminals. Note that an element’s terminal is highlighted by a red circle whenever the mouse pointer is located over it.

Once an element is selected at its terminal and then dragged onto the schematic canvas, a red dot will appear whenever the terminal is located close to the end of an already existing connection line (here shown for the RJ45 connector example):
Releasing the mouse button there will then place and connect the circuit element on the canvas. Red terminal lines illustrate that this line is still open-ended whereas blue lines indicate proper connection.

Selecting a circuit element by single-clicking on it will reveal its properties in the parameter window as shown below:

The element’s properties can be modified in the usual way by clicking into the corresponding entry field and changing the value.

Ground (GND) elements and ports can also be accessed by dragging and dropping them from the block selection pane (for ports select the Miscellaneous section), but convenient shortcuts exist for these frequently used elements:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>g</td>
<td>Place a ground element. Simply click on the end of a connection line after activating this shortcut.</td>
</tr>
<tr>
<td>p</td>
<td>Place a port element. Click on the end of a connection line to place the port</td>
</tr>
</tbody>
</table>

All elements can be dragged with the mouse to a new location while the elements stay connected via the connection lines. Furthermore, after you select an element, you can rotate it by choosing View ⇄ Tools ⇄ Rotate/Flip Tools ⇄ Rotate Left (shortcut l) and View ⇄ Tools ⇄ Rotate/Flip Tools ⇄ Rotate Right (shortcut r), respectively.
The following picture shows an exemplary external circuit where the original 8-port structure has been reduced to a 2-port device by applying loads to all the other terminals:

Once all terminals of the MWS block are connected to circuit elements, an S-parameter simulation of the structure including the external circuitry can be performed. The resulting S-matrix will have two ports in the example above, since only two external ports have been placed in the schematic (represented by yellow symbols).

In order to run an S-parameter circuit simulation, choose Simulation→Update. The circuit simulator supports a variety of different analysis options, so you will be prompted to select one of them:
Not all of these options may be available to you due to license restrictions. Here you should select S-Parameters and click OK. A dialog box will appear in which you can specify the settings of the S-parameter calculation:

The most important setting is the *Number of frequency steps* here. Clicking OK will start the S-parameter simulation of the coupled EM and circuit problem. If all simulation results of the 3D EM simulation are already present, the circuit simulation will only take a few seconds to complete. Otherwise, the missing EM simulation data will be automatically computed first.

Once the simulation is complete, the results will be added to the navigation tree. The ‘Projects’ folder will contain a list of sub-folders, each of which represent a currently opened project. All data will be stored under the folder for the corresponding project.
The S-parameters will be shown as top-level results of the project folder. Simply clicking on the ‘S-Parameters’ entry will show the external S-parameters:

![S-Parameters](image)

The schematic view also supports the parameterization of the 3D model in a straightforward way by making the structure parameters available as block parameters for the MWS block. This tight coupling of the different simulation methods allows for true EM/circuit co-simulation.

**Integration from the CST DESIGN STUDIO™’s User’s Point of View**

This integration is mainly established by two types of blocks: Dependent on the design’s requirements, you may choose between a block that only holds a reference to a MICROWAVE STUDIO® project and a block that maintains a copy of the original project. The latter one allows parametric control from within CST DESIGN STUDIO™ and takes advantage of a global repository of already calculated results, the so-called result cache.

To give you an idea of the capabilities offered by the integration, we will construct an example and demonstrate the key features in this chapter.

**Example Introduction**

The model used as example is shown in the image below. A rectangular patch antenna with two feeds having impedances of approx. 100 Ω is connected to two impedance transformers.
We assume a fixed antenna design with no parameterization. The antenna radiation frequencies are as follows:

\[ f_1 = 7 \text{ GHz for excitation at port No.1} \]
\[ f_2 = 7.5 \text{ GHz for excitation at port No.2}. \]

The transformers consist of two microstrip step discontinuities with a microstrip line of length \( l \) and width \( w \) in between:

To distinguish between the widths of transformer 1 and 2, we will call their widths \( w_1 \) and \( w_2 \), respectively.

The other line widths are defined by the patch antenna’s port impedances (approx. 100 \( \Omega \)) at one port and by the specification of 50 \( \Omega \) at the other port.

Our design goal represents a typical matching problem and can be formulated as follows: Determine values for \( l_1, l_2, w_1 \) and \( w_2 \) to obtain minimal reflection at the transformers’ input ports (50 \( \Omega \)) for the original antenna frequencies.

To simplify this task, we reduce the number of parameters by choosing \( l_1 = l_2 = 7 \text{mm} \). Thus, \( w_1 \) and \( w_2 \) remain as parameters to be optimized for demonstration purposes.

**CST MICROWAVE STUDIO® Models**

First we must set up the CST MICROWAVE STUDIO® models that we will use within our CST DESIGN STUDIO™ project. If you are not familiar with CST MICROWAVE STUDIO®, you
may read through the CST STUDIO SUITE™ Getting Started and CST MICROWAVE
STUDIO® Overview manuals first.

For both the antenna and transformer models, the substrate will have the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dielectric constant $\varepsilon_r$</td>
<td>2.2</td>
</tr>
<tr>
<td>Height</td>
<td>0.794 mm</td>
</tr>
<tr>
<td>Metallizations' thickness</td>
<td>0.05 mm</td>
</tr>
<tr>
<td>Metallizations' Material</td>
<td>PEC</td>
</tr>
</tbody>
</table>

**Antenna**

The image below shows the rectangular patch antenna of size 12.6×13.6 mm. The patch is elevated by the additional height $h_{\text{add}} = 0.5$ mm. The space between the patch and the substrate is also filled with substrate material. Therefore, the resulting substrate height below the patch is $h_{\text{patch}} = 1.294$ mm.

The feeding microstrip lines’ widths are 0.7 mm. They are located on the original substrate and end below the patch. The length $l_{\text{add}}$ between the patch’s edge and line’s end (as shown in the image below) is $l_{\text{add}} = 4$ mm.
Note that the de-embedding feature is used for both ports. The phase shifts by the lines’ lengths between the patch and the ports are not considered for the S-parameters of the model.

The frequency range set is $5 \leq f / \text{GHz} \leq 10$. The S-parameters $S_{11}$ and $S_{22}$ show minima at the antenna’s radiation frequencies $f_1$ and $f_2$:

![S-Parameter Magnitude in dB](image)

Finally, two farfield monitors should be defined at 7 GHz and 7.5 GHz to perform a final antenna calculation from within CST DESIGN STUDIO™.

**Transformer**

Although CST DESIGN STUDIO™ provides an analytical model for the microstrip step discontinuity, a CST MICROWAVE STUDIO® model of the transformer is used to demonstrate the parametric control of CST MICROWAVE STUDIO® projects from within CST DESIGN STUDIO™.

Two parameters are defined for the model of the transformer: $w$ for the transformer’s widths and $l$ for the transformer’s length. The widths for the input and output microstrip lines are defined by their impedances of 50 $\Omega$ and 100 $\Omega$. Considering the substrate defined above, we obtain 0.7 and 2.4 mm, respectively. With the initial values $l = 7$ mm and $w = 1$ mm, the transformer appears as follows:
Note that the de-embedding feature is used again for the input and the output ports of the transformer. The phase shifts by the lengths of the lines adjacent to the ports are not considered for the S-parameters of the model. Only the discontinuity effects and the transformer's length are taken into account.

CST DESIGN STUDIO™ Modeling

As mentioned in the introduction to this chapter, CST DESIGN STUDIO™ provides two types of CST MICROWAVE STUDIO blocks. In this section, we will give a short overview over the properties and usage of these blocks. For more detailed information, please have a look at the online documentation.

CST MICROWAVE STUDIO File Block

A block of this type holds a reference to a CST MICROWAVE STUDIO® project. Basically, it imports S-parameter results from there, but there is some more functionality that is of merit for the user: The block keeps track of modifications of the project that can be optionally considered in CST DESIGN STUDIO™. Furthermore, if some required results are missing in the CST MICROWAVE STUDIO® project – e.g. since only a selection of port modes have been excited – the required CST MICROWAVE STUDIO® simulation is run from within CST DESIGN STUDIO™ before the actual calculation in CST DESIGN STUDIO™ is performed.

The usage of a CST MICROWAVE STUDIO file block is quite simple: After dropping this type of block inside the design view, the 'Import CST MICROWAVE STUDIO' File dialog box is opened where you may browse for a CST MICROWAVE STUDIO® project file.

There are two additional properties that can be set while inserting the block, but that can also be modified later by customizing the block's property dialog box:

- **Store Relative Path:** You can either store the relative path or the absolute path from the current CST DESIGN STUDIO™ project to the selected CST MICROWAVE STUDIO® project. This option is disabled if the CST DESIGN STUDIO™ project has not yet been saved (as there is no path for this project at all). Then, the absolute path will be automatically stored. Both options make sense, depending on how you wish to deal with the project in future. If there is a project repository on a server it is useful to provide absolute paths because you just need to send the CST DESIGN STUDIO™ project file to a colleague who may also access the server. On the other hand, if you want to send a project file to someone who cannot access the server, perhaps by e-mail, it is more useful to copy the CST MICROWAVE STUDIO® project to a sub-folder of the current project's folder and provide the relative path.
• **Use AR filter whenever possible:** Use the AR filter function of CST MICROWAVE STUDIO® to extract the S-parameters from the time domain calculation.

A CST MICROWAVE STUDIO file block is represented by a small image of the 3D model and a small arrow on the lower left indicating that it is the file block. The number of (internal) ports corresponds to the number of (waveguide or discrete) ports defined in the CST MICROWAVE STUDIO® model.

Let us examine the contents of a CST MICROWAVE Studio file block’s property dialog box. Because this type of block provides no parameters, the initial page shown is the ‘General’ page.

![Properties for MWS1 (patch.cst)](image)

A CST MICROWAVE Studio file block is always frequency bounded. As usual, the limits are displayed in the 'General' page as shown above. Furthermore, the file that the block refers to is displayed there. You can again choose between an absolute path and a relative path. However, this option is disabled here because the CST DESIGN STUDIO™ project has not yet been saved. The absolute path is therefore considered.

Moreover, there are three buttons: **Browse**, **Edit** and **Convert**.

Pressing **Browse** opens the ‘Import CST MICROWAVE STUDIO File’ dialog box again where you can browse for a different project. Frequency bounds and the number of internal ports will be changed according to the new file’s contents. Connections will be kept if there are some ports with identical names contained in the new project, otherwise the links will be deleted.

Pressing **Edit** opens the CST MICROWAVE STUDIO® project inside your CST DESIGN ENVIRONMENT™.

Pressing **Convert** converts this block to a parameterized CST MICROWAVE STUDIO block. The arrow inside the block’s image will then disappear. We refer to this type of block in the next section.
You can also choose *Use the AR filter whenever possible* here again as already mentioned above.

**CST MICROWAVE STUDIO Block**

A CST MICROWAVE STUDIO block allows you to parametrically deal with a CST MICROWAVE STUDIO® project. You can insert it from the *Miscellaneous* section of the block selection pane. The ‘Import CST MICROWAVE STUDIO File’ dialog box will be opened where you can browse for the project.

In contrast to the CST MICROWAVE STUDIO file block, this type of block does not refer to the selected project. Instead, the essential project files will be stored by the block. To recalculate the results for the block or to open this project in a CST MICROWAVE STUDIO® instance embedded in CST DESIGN STUDIO™, these project files will be copied to a sub-folder of the current project's folder. However, you should never modify these files in an external CST MICROWAVE STUDIO® instance, as this might lead to inconsistencies.

The most relevant feature supported by this type of block is the control of the CST MICROWAVE STUDIO® project's parameters from within CST DESIGN STUDIO™. The properties available inside the 'Parameters' page of the block's property dialog box correspond to the independent parameters of the related project.

**Result Cache**

A very useful addition to the parameter control is the usage of a cache, in which already calculated results for S-parameters and port impedances are stored. Such a cache entry is created after assigning a project to a block for the first time. This cache will be reused if you associate another block with this project, even if it was copied to a different location or stored under a different file name. A new cache entry is added only if the project was modified in the meantime. However, a cache entry is not identified by the project's path or file name, but rather by the project's contents.

A cache may be used by a group of users and each user may use several caches simultaneously. To define the caches that you want to use, choose *Edit* ⇒ *Set Cache Paths* from the main menu. The following dialog box is opened where you can specify an arbitrary number of cache paths. The paths can be ordered according to their priority (imagine that two caches may contain entries for the same project).

The results for each project are stored separately for different solver and mesh settings (refer to the CST MICROWAVE STUDIO® manual to get more information about these settings). They
can be accessed (for read only) by selecting the CST MICROWAVE STUDIO block and choosing Components ⇒ View Cache from the main menu or by choosing View Cache from the block’s context menu. The ‘Cache Overview’ dialog box is then opened. Within this dialog box you can manage the cache entry that is associated with the block:

- The two selector boxes at the top of the dialog box allow you to switch between the stored parameter sets. Several sets can be stored for each solver that can be selected with the control to the right.
- You may delete the currently selected set from the cache by pressing the Delete button.
- To display the results associated with the currently selected parameter set, just press the Show Set button.
- Furthermore, the cache path that this entry is based on is displayed.

To quickly remove all cache entries (or all cache entries related to a single solver), you may more efficiently use Components ⇒ Delete Cache from the main menu or Delete Cache from the block’s context menu.

It is worth mentioning that the availability of a result cache is very powerful, especially if interpolation (that is referred to below) is used. Once the cache is filled, e.g. by a parameter sweep, you can quickly obtain interpolated results from 3D simulations and even perform an optimization without waiting for time-consuming 3D simulations.

CST DESIGN STUDIO™ Simulation

The CST DESIGN STUDIO™ model of our example consists of three blocks:

- A CST MICROWAVE STUDIO file block is used for the antenna because it is a fixed model that does not have any parameters.
- Two CST MICROWAVE STUDIO blocks are used to create two independent copies of the previously created transformer model. Both models offer the parameter w that will be used to optimize each transformer from within CST DESIGN STUDIO™.
Add these blocks to your (initially empty) project, and connect them as shown below. Also, insert two external ports there and connect them to the 50 Ω ports.

Now some parameters need to be defined. These parameters will be used to optimize the match between the antenna and the external ports. Use the docked parameter list control as explained during the ‘Quick Tour’, and create the parameters width1 = 1.0 and width2 = 1.0.

Whenever a CST MICROWAVE STUDIO block is selected, its parameters are displayed in the docked parameter list control.

The transformer blocks show two parameters: w = 1 mm and l = 7 mm. They are initially set by the corresponding CST MICROWAVE STUDIO® project. Modify the parameter w as follows:

Transformer No. 1: (The one connected to the antenna’s port No.1) w = width1
Transformer No. 2: w = width2

These modifications can also be performed on the ‘Parameters’ page of the ‘Block Properties’ dialog box (select the block and choose Edit→Properties from the main menu).

Since the port impedances are numerically evaluated, they depend on the mesh used for the 3D model. As a consequence, the port impedances of the transformers and the antenna may be slightly different although the port regions are geometrically identical. It is possible to correct these differences so that the mismatch between the ports will not cause any reflections.
This option can be set on the ‘Renormalization’ page of the ‘Block Properties’ dialog box. By default, differences lower than 15% will be ignored for a connection of a CST MICROWAVE STUDIO® block with another block or with an external port. This default setting is useful for our example. We could also choose Never renormalize here since we are sure that any mismatch is yielded by different discretizations only.

CST DESIGN STUDIO™ is able to evaluate results for a CST MICROWAVE STUDIO block by interpolation. To utilize this feature, check Components ⇒ Enable Interpolation to make sure that the interpolation is not turned off. Moreover, proper interpolation settings need to be chosen for each block. Go to the ‘Solver’ page of the ‘Block Properties’ dialog box that contains the following frame:

Make sure that the Use interpolation option is switched on (this is the default setting). Click Details to assign proper interpolation ranges to the block’s parameters. The ‘Interpolation Details’ dialog box opens to display a list of the block’s parameters, their ranges of validity (if they are limited), ranges for the interpolation, and numbers of samples for the interpolation.
Because only the parameter $w$ will be modified during our optimization process, keep the values for $l$. For $w$, choose a wider interpolation range: $1 \leq w \leq 2$. Keep 5 for the number of samples for this parameter.

To apply this modification to both transformer blocks, choose "Assign values to all blocks of this type in project" at the bottom of the dialog box. It is useful to provide identical interpolation settings for them as they share the same cache since they are derived from the same CST MICROWAVE STUDIO® project. Therefore, all results for different parameter sets calculated for the first block will be available for the other one, and vice versa. Because the parameter $l$ will not be modified any more, only five 3D calculations (the number of samples specified for $w$) will be performed at maximum if the values for $w$ do not exceed the interpolation range.

Finally, confirm the settings by clicking OK and leave the ‘Block Properties’ dialog box.
To obtain an initial S-parameter result, an S-parameter simulation task needs to be defined. Choose *Simulation* > *New Task* from the main menu to open the 'Select Simulation Task' dialog box, and select 'S-Parameters' there. The 'S-Parameters Simulation Task' dialog box will open.

Since frequency ranges are specified for CST MICROWAVE STUDIO® projects, the blocks' valid frequency ranges are limited as well. Therefore, the *Maximum frequency range* option can be chosen inside the *S-Parameter Settings* frame. Keep all default settings, and click *OK* to add the simulation task to the project.
Update the results now by choosing Simulation→Update from the main menu. The transformer blocks’ parameter values are identical. Consequently, a single 3D calculation is performed for both of them. The second one can read the results from the cache.

Look at the design’s S-parameter results now by selecting the corresponding item in the navigation tree:

Obviously, this initial result is quite good. The relatively low reflections indicate a very good match. However, let’s try to obtain even better results by optimization.

**Optimization**

The optimizer tool has already been presented in detail during the ‘Quick Tour’. The following description focuses on the parameter and goal settings for our example.

To open the ‘Optimizer’ dialog box, choose Simulation→Optimize from the main menu. The ‘Parameters’ page is initially active where you may choose the parameters that will be taken into account during the optimization process. Furthermore, you may set a range and an associated number of samples for each parameter there.
The global parameters width1 and width2 are assigned to the properties w of the transformer blocks. The interpolation range \(1 \leq w \leq 2\) and five samples are set for this property, i.e. 3D calculations will be performed for \(w = 1, w = 1.25, w = 1.5, w = 1.75\) and \(w = 2\) only. When setting ranges for width1 and width2, it is useful to make sure that these interpolation samples are samples for the optimization as well. The easiest way to fulfill this requirement is to choose \(1 \leq \text{width1, width2} \leq 2\) and five samples.

**Please note:** The specification of three samples would also fulfill this requirement as results would be calculated for \(\text{width1} = 1, \text{width1} = 1.5\) and \(\text{width1} = 2\). Nine samples would again satisfy this condition. However, whereas three samples would provide a coarser sampling than the blocks’ interpolations, nine samples would lead to a finer sampling. Because identical interpolation schemes are used for the blocks’ interpolations and for the optimization, there is no advantage in choosing a finer sampling for the optimization.

Setting up the goals is straightforward. The minima for \(S_{11}\) and \(S_{22}\) are already located at the right position. To obtain lower values for them, the following goals are defined:

\[
\text{Minimize } S_{11} \text{ for } f = 7000 \text{ MHz and} \\
\text{Minimize } S_{22} \text{ for } f = 7500 \text{ MHz.}
\]

The dialog box below shows the definition of the goal for \(S_{11}\). The definition of the second goal is quite similar and differs by the selection for Data and by the specified frequency only.
The 'Goals' page now displays a list containing both previously defined goals:

The optimization setup is complete now. Start the optimization by clicking the Start button. Because the results for width1 = 1.0, width2 = 1.0 are already available, only four 3D simulations are performed during the optimization process for the remaining samples. The 'Info' page displays information about the goal values and the optimized parameters. After the optimization is complete, a message appears in the info tab as follows:
As the difference of the first and the best goal values indicates, the optimization was successful. The following picture shows that both, $S_{11}$ and $S_{22}$ could be improved at the desired frequencies:
Antenna Calculation

If your model contains a CST MICROWAVE STUDIO block or a CST MICROWAVE STUDIO file block and a field monitor is defined in the project associated with this block, CST DESIGN STUDIO™ allows you to calculate the field as a result of the network excited by a given excitation. This ‘Combine Result’ feature is available as an addition to the S-parameter or the AC simulation task.

Let us now perform a final antenna calculation with the optimized parameters of our CST DESIGN STUDIO™ model. Therefore, open the ‘S-Parameters Simulation Task’ dialog box for the existing S-parameter simulation task. Change to the ‘Combine Results’ page where all settings for farfield calculations from within CST DESIGN STUDIO™ can be accessed.

By default, the ‘Combine Results’ calculation is disabled. Select the Combine results option to switch it on. Moreover, the block describing the antenna needs to be selected in the Block selector box. Choose the block’s name, and make sure that the correct preview image is displayed next to it.

Furthermore, select the Calculate farfields only option at the button of this dialog box. Otherwise, all field monitors available in the associated CST MICROWAVE STUDIO® project would be considered.

As mentioned above, two monitors at 7 GHz and 7.5 GHz have been specified for the antenna’s CST MICROWAVE STUDIO® project. Because the task’s frequency range is wide enough, the driven farfield results will be computed for both frequencies.
Because no excitation has yet been defined for the antenna calculation, complex amplitudes need to be assigned to the external ports. You should therefore click the Define Excitation button to open the 'Define Excitations' dialog box.

Specify an excitation for port No. 1 only, i.e. assign 1 to port No. 1’s amplitude and keep 0 for port No. 2’s amplitude as well as for the phases of both ports. After confirming the excitation’s definition and the simulation task’s modification, you can update the results.

The following output will be written to the message window:

- Performing task S-Parameters1...
- Using interpolation for calculating "MwSPARA1" S-Parameters!
- Calculating sampling points for block "MwSPARA1"...
- Sampling point 1 of 3 [read from cache]
- Sampling point 2 of 3 [read from cache]
- Sampling point 3 of 3 [read from cache]
- Calculating fields with excitations from the network for "MwS1" at 7500 MHz.
- Calculating fields with excitations from the network for "MwS1" at 7000 MHz.
- Task S-Parameters1 successfully completed.

Please note: No 3D simulation is performed because the transformer’s results are read from the cache and the antenna’s results are already available. Before the task is successfully completed, the farfields are calculated for the defined excitation.

The results of the farfield calculations are now available in the antenna block’s CST MICROWAVE STUDIO® project. You can access them by selecting the block and choosing Edit from its context menu that will open the project.
The navigation tree’s ‘Farfields’ folder contains additional entries labeled with '[S-Parameters1]'. These items contain the farfields for the excitation as defined in the simulation task.

For instance, selecting the item ‘farfield (f=7) [S-Parameters1]’ leads to the display of the directivity’s magnitude in dBi:
Chapter 4 – Finding Further Information

After carefully reading this manual, you will already have a basic understanding of how to use CST DESIGN STUDIO™ efficiently for your own problems. However, when you are creating your own designs, many questions will arise. In this chapter we will give you a quick overview of the available documentation.

Online Reference Documentation

You can access the CST STUDIO SUITE™ online help system’s overview page at any time by choosing Help⇒Help Contents from the menu bar.

In each of the dialog boxes there is a specific Help button which will directly open the corresponding manual page. Additionally the F1 key gives some context sensitive help when a particular mode is active. For instance, by pressing the F1 key while a block is selected, you will obtain some information about the block’s properties.

Whenever no specific information is available, pressing the F1 key will open an overview page from which you may navigate through the online help system.

Please refer to the CST STUDIO SUITE™ Getting Started manual for more information about how to use the online help system.

Examples

The installation directory of CST DESIGN ENVIRONMENT™ contains an examples subdirectory consisting of a couple of typical application examples. A quick overview of the existing examples can be obtained by browsing through the descriptions of the examples inside the online help system. These examples may contain helpful hints that can be transferred to your particular application.

Access Technical Support

After you have taken your first steps solving your own applications within CST DESIGN STUDIO™, you should send your recent project file (with the extension ‘cst’) to the technical support team. Even if you have successfully obtained a solution, the problem specification might still be improved in order to get even better results within shorter calculation times.

The support area on our homepage (www.cst.com) also contains a lot of very useful and frequently updated information. A simplified access to this area is provided by choosing Help⇒Online Support. You only need to enter your user name and password once. Afterward, the support area will be opened automatically whenever you choose this menu command.
Macro Language Documentation

More information concerning the built-in macro language can be accessed through the VBA overview page of the online help system. The macro language’s documentation consists of four parts:

- An overview and a general description of the macro language.
- A description of all CST DESIGN STUDIO™ specific macro language extensions.
- A syntax reference of the Visual Basic for Applications compatible macro language.
- Some documented macro examples.

History of Changes

The history of changes between several releases of the program is also available via the online help system. Since there are many new features in each new version, you should browse through the list even if you are already familiar with one of the previous releases.
CST 视频培训课程推荐

CST 微波工作室 (CST Microwave Studio) 是 CST 工作室套装中最核心的一个子软件, 主要用于三维电磁问题的仿真分析, 可计算任意结构任意材料电大宽带的电磁问题。广泛应用于高频/微波无源器件的仿真设计、各种类型的天线设计、雷达散射截面分析、电磁兼容分析和信号完整性分析等各个方面。

易迪拓培训 (www.edatop.com) 推出的 CST 微波工作室视频培训课程由经验丰富的专家授课，旨在帮助用户能够快速地学习掌握 CST 微波工作室的各项功能、使用操作和工程应用。购买 CST 教学视频培训课程套装，还可超值赠送 3 个月免费在线学习答疑，让您学习无忧。

CST 学习培训课程套装

该培训课程由易迪拓培训联合微波 EDA 网共同推出，是最全面、系统、专业的 CST 微波工作室培训课程套装，所有课程都由经验丰富的专家授课，视频教学，可以帮助您从零开始，全面系统地学习 CST 微波工作室的各项功能及其在微波射频、天线设计等领域的设计应用。且购买该套装，还可超值赠送 3 个月免费学习答疑…


HFSS 天线设计培训课程套装

套装共含 5 门视频培训课程，课程从基础讲起，内容由浅入深，理论介绍和实际操作讲解相结合，全面系统的讲解了 CST 微波工作室天线设计的全过程。是国内最全面、最专业的 CST 天线设计课程，可以帮助您快速学习掌握如何使用 CST 设计天线，让天线设计不再难…

课程网址：http://www.edatop.com/peixun/cst/127.html

更多 CST 视频培训课程：

- CST 微波工作室入门与应用详解 — 中文视频教程

- CST 微波工作室天线设计详解 — 中文视频培训教程

- CST 阵列天线仿真设计实例详解 — 中文视频教程
  阵列天线设计专业性要求很高，因此相关培训课程是少之又少，该门培训课程由易迪拓培训重金聘请专家讲解；课程网址：http://www.edatop.com/peixun/cst/123.html

- 更多 CST 培训课程，敬请浏览：http://www.edatop.com/peixun/cst
关于易迪拓培训：

易迪拓培训(www.edatop.com)由数名来自于研发第一线的资深工程师发起成立，一直致力和专注于微波、射频、天线设计研发人才的培养；后于2006年整合合并微波 EDA 网(www.mweda.com)，现已成为国内最大的微波射频和天线设计人才培养基地，成功推出多套微波射频以及天线设计相关培训课程和 ADS、HFSS 等专业软件使用培训课程，广受客户好评；并先后与人民邮电出版社、电子工业出版社合作出版了多本专业图书，帮助数万名工程师提升了专业技术能力。客户遍布中兴通讯、研通高频、埃威航电、国人通信等多家国内知名公司，以及台湾工业技术研究院、永业科技、全一电子等多家台湾地区企业。

我们的课程优势：

※ 成立于2004年，10多年丰富的行业经验
※ 一直专注于微波射频和天线设计工程师的培养，更了解该行业对人才的要求
※ 视频课程，既能达到现场培训的效果，又能免除您舟车劳顿的辛苦，学习工作两不误
※ 经验丰富的一线资深工程师讲授，结合实际工程案例，直观、实用、易学

联系我们：

※ 易迪拓培训官网：http://www.edatop.com
※ 微波 EDA 网：http://www.mweda.com
※ 官方淘宝店：http://shop36920890.taobao.com